Skip to Main Content
Status Under review
Created by Harry Mitchell
Created on Jul 23, 2021

Make a Lite version of RingCentral IOS app (for devices lower than ios 12)

Please make a RingCentral ios app that is compatible to phones prior to IOS 12 because not everyone has Ios 12 on their Iphone or Ipad. It would be useful to make a Lite version that supports devices from IOS 8. Only minimal features needed. The former RC Meetings app supports it but the new RC is too hard on device requirement.